// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<(\w*?)>.*<.*>").unwrap();
let string = "<soapenv:Envelope...>
<soapenv:Header/>
<soapenv:Body>
<urn:ClosedRequest>
<ExternalApplicationNumber>4816</ExternalApplicationNumber>
<PersonDataList>
<!--1 or more repetitions:-->
<PersonData>
<PersonExternalIdentifier>sa1</PersonExternalIdentifier>
<EligibilityEndDate>2017-12-31</EligibilityEndDate>
<!--Optional:-->
<ReasonCode>60</ReasonCode>
<PersonDeathDate>2015-09-02</PersonDeathDate>
</PersonData>
</PersonDataList>
</urn:ClosedRequest>
</soapenv:Body>
</soapenv:Envelope>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}