import Foundation
let pattern = #"<(\w*?)>.*<.*>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<soapenv:Envelope...>
<soapenv:Header/>
<soapenv:Body>
<urn:ClosedRequest>
<ExternalApplicationNumber>4816</ExternalApplicationNumber>
<PersonDataList>
<!--1 or more repetitions:-->
<PersonData>
<PersonExternalIdentifier>sa1</PersonExternalIdentifier>
<EligibilityEndDate>2017-12-31</EligibilityEndDate>
<!--Optional:-->
<ReasonCode>60</ReasonCode>
<PersonDeathDate>2015-09-02</PersonDeathDate>
</PersonData>
</PersonDataList>
</urn:ClosedRequest>
</soapenv:Body>
</soapenv:Envelope>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)