import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-](?:(a)|(bc))+(?:(a)|(bc))*+([+-x\\/](?:(a)|(bc))+(?:(a)|(bc))*)*$";
final String string = "+a-bc-a\n"
+ "-bc+a-a\n"
+ "-b+a+ab";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}