const regex = /^[+-](?:(a)|(bc))+(?:(a)|(bc))*+([+-x\/](?:(a)|(bc))+(?:(a)|(bc))*)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-](?:(a)|(bc))+(?:(a)|(bc))*+([+-x\\\/](?:(a)|(bc))+(?:(a)|(bc))*)*$', 'gm')
const str = `+a-bc-a
-bc+a-a
-b+a+ab`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);