const regex = /(?ix) (?:c \K) | (?<=\G) .*? \K \w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ix) (?:c \\K) | (?<=\\G) .*? \\K \\w+', 'gm')
const str = `c =word &word 2-2=0
c 22 ^&*w0rd*
+word &word `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}