$re = '/(?ix) (?:c \K) | (?<=\G) .*? \K \w+/m';
$str = 'c =word &word 2-2=0
c 22 ^&*w0rd*
+word &word ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);