using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ix) c \K | (?<=\G) .*? \K \w+";
string input = @"c word & word = word + word
c 12 = word + word
word & word = word + word
12 = word + word";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}