$re = '/(?ix) c \K | (?<=\G) .*? \K \w+/m';
$str = 'c word & word = word + word
c 12 = word + word
word & word = word + word
12 = word + word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);