re = /(?ix) c \K | (?<=\G) .*? \K \w+/m
str = 'c word & word = word + word
c 12 = word + word
word & word = word + word
12 = word + word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end