$re = '/^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$/m';
$str = 'http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);