re = /^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$/m
str = 'http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end