import re
regex = re.compile(r"^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$", flags=re.MULTILINE)
test_str = ("http://regex101.com/r/mH1fN5\n"
"http://regex101.com/r/fW0vZ2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")