using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)\\[{}]|(\{(?:""[^""\\]*(?:\\.[^""\\]*)*""|[^{}]*)(?:\\.(?:""[^""\\]*(?:\\.[^""\\]*)*""|[^{}]*))*})";
string input = @"{""asd""} - {""asd""}
\{""test""}
- No match
\\{""Apple juice}""} - {""Apple juice}""}
{{""Test""}} - {""Test""}
{ddd""k""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}