$re = '/(?<!\\\\)\\\\[{}]|(\{(?:"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|[^{}]*)(?:\\\\.(?:"[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|[^{}]*))*})/';
$str = '{"asd"} - {"asd"}
\\{"test"}
- No match
\\\\{"Apple juice}"} - {"Apple juice}"}
{{"Test"}} - {"Test"}
{ddd"k"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);