re = /(?<!\\)\\[{}]|(\{(?:"[^"\\]*(?:\\.[^"\\]*)*"|[^{}]*)(?:\\.(?:"[^"\\]*(?:\\.[^"\\]*)*"|[^{}]*))*})/
str = '{"asd"} - {"asd"}
\\{"test"}
- No match
\\\\{"Apple juice}"} - {"Apple juice}"}
{{"Test"}} - {"Test"}
{ddd"k"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end