import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img\\s*src=\"[^\"]+\"\\s*alt=\"AAA\"\\s*width=\"24\"\\s*height=\"24\"\\s*\\/>\\s*([^<]+?)\\s*<br\\s*\\/>";
final String string = "<div><img src=\"images/stories/2014/AAA.gif\" alt=\"AAA\" width=\"24\" height=\"24\" /> THE PRODUCTION OF: PLASTIC BOTTLES <br /></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}