const regex = /<img\s*src="[^"]+"\s*alt="AAA"\s*width="24"\s*height="24"\s*\/>\s*([^<]+?)\s*<br\s*\/>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img\\s*src="[^"]+"\\s*alt="AAA"\\s*width="24"\\s*height="24"\\s*\\\/>\\s*([^<]+?)\\s*<br\\s*\\\/>', '')
const str = `<div><img src="images/stories/2014/AAA.gif" alt="AAA" width="24" height="24" /> THE PRODUCTION OF: PLASTIC BOTTLES <br /></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}