package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b((\d{1,3})|([1-6]\d{3})|(7[0-5]\d{2})|(760[0-3]))\b`)
var str = `1 100 1700 710 7400 7500 7600 17000 7603 7604 6999 7599`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}