const regex = /\b((\d{1,3})|([1-6]\d{3})|(7[0-5]\d{2})|(760[0-3]))\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((\\d{1,3})|([1-6]\\d{3})|(7[0-5]\\d{2})|(760[0-3]))\\b', 'g')
const str = `1 100 1700 710 7400 7500 7600 17000 7603 7604 6999 7599`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}