// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b((\d{1,3})|([1-6]\d{3})|(7[0-5]\d{2})|(760[0-3]))\b").unwrap();
let string = "1 100 1700 710 7400 7500 7600 17000 7603 7604 6999 7599";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}