use strict;
my $str = ' abc def " gh i " jkl " m n o p " qrst ';
my $regex = qr/\s(?=(?:"[^"]*"|[^"])*$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";