re = /\s(?=(?:"[^"]*"|[^"])*$)/m
str = ' abc def " gh i " jkl " m n o p " qrst '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result