$re = '/\s(?=(?:"[^"]*"|[^"])*$)/m';
$str = ' abc def " gh i " jkl " m n o p " qrst ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;