using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\w)[""'?]|,(?= )";
string substitution = @"";
string input = @"""'This has punctuation, and it's hard to remove. ?"" ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}