use strict;
my $str = '"\'This has punctuation, and it\'s hard to remove. ?" ';
my $regex = qr/(?<!\w)["'?]|,(?= )/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";