const regex = new RegExp('(?<!\\w)["\\'?]|,(?= )', 'g')
const str = `"'This has punctuation, and it's hard to remove. ?" `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);