#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(:61:[0-9]{1,6}[0-9]{4}C[0-9]+,[0-9]{0,2})(NMSC.+)(\r?\n:86:RGT FACT)|\G(?!^))[ .](\d{5})"
Local $sString = ":61:2204210421C1339,57NMSCTOPF2510474511//GBBK031SCT TOPF2510474511" & @CRLF & _
":86:RGT FACT 17133 TANQ BROERS SA/RGT39370 TANQ BROERS SA48 AVENUE D'ABCDE" & @CRLF & _
":61:2204270427C4808,37NMSCTOPF2520477320//GBJ6009SCT TOPF2520477320" & @CRLF & _
":86:RGT FACT 17274.17442.17546 TANQ BROERS SA/RGT39370 TANQ BROERS SA48 AVENUE D'ABCDE" & @CRLF & _
":61:2203290329C5518,16NMSCTOPF2485471711//GBCJ001SCT TOPF2485471711" & @CRLF & _
":86:RGT FACT.16794 16918 17079 TANQ BROERS SA/RGT39370 TANQ BROERS SA48 AVENUE D'ABCDE"
Local $sSubst = "$1$2$3INV$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)