# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(:61:[0-9]{1,6}[0-9]{4}C[0-9]+,[0-9]{0,2})(NMSC.+)(\r?\n:86:RGT FACT)|\G(?!^))[ .](\d{5})"
test_str = (":61:2204210421C1339,57NMSCTOPF2510474511//GBBK031SCT TOPF2510474511\n"
":86:RGT FACT 17133 TANQ BROERS SA/RGT39370 TANQ BROERS SA48 AVENUE D'ABCDE\n"
":61:2204270427C4808,37NMSCTOPF2520477320//GBJ6009SCT TOPF2520477320\n"
":86:RGT FACT 17274.17442.17546 TANQ BROERS SA/RGT39370 TANQ BROERS SA48 AVENUE D'ABCDE\n"
":61:2203290329C5518,16NMSCTOPF2485471711//GBCJ001SCT TOPF2485471711\n"
":86:RGT FACT.16794 16918 17079 TANQ BROERS SA/RGT39370 TANQ BROERS SA48 AVENUE D'ABCDE")
subst = "$1$2$3INV$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.