using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<((?>>>|[^>]+)*)>";
string input = @"<test>>more> or even more>
And <here> it matches.
And <also>>here> is a match
Im <guessing this is>> correct.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}