re = /<((?>>>|[^>]+)*)>/
str = '<test>>more> or even more>
And <here> it matches.
And <also>>here> is a match
Im <guessing this is>> correct.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end