$re = '/<((?>>>|[^>]+)*)>/';
$str = '<test>>more> or even more>
And <here> it matches.
And <also>>here> is a match
Im <guessing this is>> correct.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);