import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!LogL=)\\d";
final String string = " 7 LogL=-3695.47 S2= 9.0808 1891 df 2.263 0.2565 \n"
+ " 9 LogL= 2456.30 S2= 1.2789 1785 df 1.244 0.1354 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}