import re
regex = re.compile(r"(?!LogL=)\d")
test_str = (" 7 LogL=-3695.47 S2= 9.0808 1891 df 2.263 0.2565 \n"
" 9 LogL= 2456.30 S2= 1.2789 1785 df 1.244 0.1354 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")