re = /(?!LogL=)\d/
str = ' 7 LogL=-3695.47 S2= 9.0808 1891 df 2.263 0.2565
9 LogL= 2456.30 S2= 1.2789 1785 df 1.244 0.1354 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end