# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b.{1,25})(?:\s+|$)/\1\n/gui;t' <<< "Please write a program that breaks this text into small chucks. Each chunk should have a maximum length of 25 "