$re = '/(\b.{1,25})(?:\s+|$)/ui';
$str = 'Please write a program that breaks this text into small chucks. Each chunk should have a maximum length of 25 ';
$subst = "\1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;