const regex = /(\b.{1,25})(?:\s+|$)/gui;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b.{1,25})(?:\\s+|$)', 'gui')
const str = `Please write a program that breaks this text into small chucks. Each chunk should have a maximum length of 25 `;
const subst = `\1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);