package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*\n){3}`)
var str = `Auth= bigben.com\\Dileja
Server = ringring.com
Config = teststringA[XXXXXXXXXXXXXXXXXXX...until EOL
X]Auth= dingdong.com\\Debyyy
Server = testtest.com
Config = teststringB
X]Auth= dingdong.com\\Debyyy
Server = testtest.com
Config = teststringB
X]Auth= dingdong.com\\Debyyy
Server = testtest.com
Config = teststringB
X]Auth= dingdong.com\\Debyyy
Server = testtest.com
Config = teststringB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}