// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*\n){3}").unwrap();
let string = "Auth= bigben.com\\\\Dileja
Server = ringring.com
Config = teststringA[XXXXXXXXXXXXXXXXXXX...until EOL
X]Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
X]Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
X]Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
X]Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}