const regex = new RegExp('(?:(?# Pattern before filename
)(?:\\[download\\] )?Destination: (?#
)|(?#
)\\[download\\] (?#
)|(?#
)Adding metadata to \\"(?#
))(?#
)((?# CAPTURE GROUP: filename pattern
)\\/?[^\\/\\\\\\n]+(?:\\/|\\\\)(?# Capture first folder
)(?:(?#
)[^\\n\\.]*(?# Stop capturing if point, to check
)(?!\\.f\\d{1,4}\\.(?:webm|mov|mp4))(?# Checking this is not a partial download
)\\.(?# Can now capture the point
))+(?#
)(?:webm|mov|mp4)(?#
))(?#
)\\n?', 'gm')
const str = `=============================
GOOD TESTS
=============================
[download] /root/.local/share/ICONO_TESTS/1678445152615210072_0.33914607510068406/yt-videos/BURGER KLEAN - 1080.mp4 has already been downloaded
[download] /root/.local/share/ICONO_TESTS/small/yt-videos/hello.mp4 has already been downloaded
[download] /root/local/share/ICONO_TESTS/small/yt-videos/hello.mp4 has already been downloaded
Destination: /root/.local/share/ICONO_TESTS/1678445152615210072_0.33914607510068406/yt-videos/Hi Anxiety: Lana Condor - 1080.mp4
[download] Destination: /root/.local/share/ICONO_TESTS/1678445152615210072_0.33914607510068406/yt-videos/#histoire #vrai #fyp #foryou #pourtoi #fyp - NA.mp4
Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.webm
Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.webm
Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO.webm
Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO_123.webm
Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO_1.2.3.mp4
xxx Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov
xxx Adding metadata to "C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov"
[Metadata] Adding metadata to "C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov"
[Metadata] Adding metadata to "C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov"
[Metadata] Adding metadata to "/home/ezalos/.local/share/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.mov"
[Metadata] Adding metadata to "/home/ezalos/.local/share/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.mov"
Adding metadata to "C:\\Users\\Adrien\\AppData\\Local\\ICONO\\ICONO_TESTS\\1678715744635004900_0.6505223019081934\\yt-videos\\BURGER KLEAN - 1080.mp4
=============================
BAD TESTS
=============================
def test_download(browser: Chrome):
app_actions = AppActions(browser, test_name="test_download")
app_actions.screenshot()
for url in url_to_test:
file_path = app_actions.download_video(url)
> assert os.path.isfile(file_path)
E AssertionError: assert False
E + where False = <function isfile at 0x000002D095AFF160>('C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.f248.webm')
E + where <function isfile at 0x000002D095AFF160> = <module 'ntpath' from 'C:\\\\Users\\\\Adrien\\\\mambaforge\\\\envs\\\\ICONO-prod\\\\lib\\\\ntpath.py'>.isfile
E + where <module 'ntpath' from 'C:\\\\Users\\\\Adrien\\\\mambaforge\\\\envs\\\\ICONO-prod\\\\lib\\\\ntpath.py'> = os.path
Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.f248.webm
Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.f248.mov
DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 0.1% of ~ 966.70KiB at 43.60KiB/s ETA 00:22 (frag 0/1)
DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 0.3% of ~ 966.70KiB at 127.60KiB/s ETA 00:07 (frag 0/1)
DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 0.7% of ~ 966.70KiB at 291.21KiB/s ETA 00:03 (frag 0/1)
DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 1.6% of ~ 966.70KiB at 610.67KiB/s ETA 00:01 (frag 0/1)
DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 3.2% of ~ 966.70KiB at 1.21MiB/s ETA 00:00 (frag 0/1)
DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 6.5% of ~ 966.70KiB at 2.30MiB/s ETA 00:00 (frag 0/1)
DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 13.1% of ~ 966.70KiB at 4.33MiB/s ETA 00:00 (frag 0/1)
DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 26.4% of ~ 966.70KiB at 8.06MiB/s ETA 00:00 (frag 0/1)
DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 52.9% of ~ 966.70KiB at 14.72MiB/s ETA 00:00 (frag 0/1)
DEBUG : 35955 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 100.0% of ~ 966.70KiB at 25.08MiB/s ETA 00:00 (frag 0/1)
DEBUG : 35955 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 100.0% of ~ 966.70KiB at 24.67MiB/s ETA 00:00 (frag 1/1)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}