import re
regex = re.compile((r"(?:(?# Pattern before filename\n"
r" )(?:\[download\] )?Destination: (?#\n"
r")|(?#\n"
r" )\[download\] (?#\n"
r")|(?#\n"
r" )Adding metadata to \"(?#\n"
r"))(?#\n"
r")((?# CAPTURE GROUP: filename pattern\n"
r" )\/?[^\/\\\n]+(?:\/|\\)(?# Capture first folder\n"
r" )(?:(?#\n"
r" )[^\n\.]*(?# Stop capturing if point, to check\n"
r" )(?!\.f\d{1,4}\.(?:webm|mov|mp4))(?# Checking this is not a partial download\n"
r" )\.(?# Can now capture the point\n"
r" ))+(?#\n"
r" )(?:webm|mov|mp4)(?#\n"
r"))(?#\n"
r")\n?"), flags=re.MULTILINE)
test_str = ("=============================\n"
" GOOD TESTS\n"
"=============================\n"
"[download] /root/.local/share/ICONO_TESTS/1678445152615210072_0.33914607510068406/yt-videos/BURGER KLEAN - 1080.mp4 has already been downloaded\n"
"[download] /root/.local/share/ICONO_TESTS/small/yt-videos/hello.mp4 has already been downloaded\n"
"[download] /root/local/share/ICONO_TESTS/small/yt-videos/hello.mp4 has already been downloaded\n"
"Destination: /root/.local/share/ICONO_TESTS/1678445152615210072_0.33914607510068406/yt-videos/Hi Anxiety: Lana Condor - 1080.mp4\n"
"[download] Destination: /root/.local/share/ICONO_TESTS/1678445152615210072_0.33914607510068406/yt-videos/#histoire #vrai #fyp #foryou #pourtoi #fyp - NA.mp4\n"
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.webm\n"
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.webm\n"
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO.webm\n"
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO_123.webm\n"
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO_1.2.3.mp4\n"
"xxx Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov\n"
"xxx Adding metadata to \"C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov\"\n"
"[Metadata] Adding metadata to \"C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov\"\n"
"[Metadata] Adding metadata to \"C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.mov\"\n"
"[Metadata] Adding metadata to \"/home/ezalos/.local/share/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.mov\"\n"
"[Metadata] Adding metadata to \"/home/ezalos/.local/share/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.mov\"\n\n"
"Adding metadata to \"C:\\Users\\Adrien\\AppData\\Local\\ICONO\\ICONO_TESTS\\1678715744635004900_0.6505223019081934\\yt-videos\\BURGER KLEAN - 1080.mp4\n\n"
"=============================\n"
" BAD TESTS\n"
"=============================\n"
" def test_download(browser: Chrome):\n"
" app_actions = AppActions(browser, test_name=\"test_download\")\n"
" app_actions.screenshot()\n"
" for url in url_to_test:\n"
" file_path = app_actions.download_video(url)\n"
"> assert os.path.isfile(file_path)\n"
"E AssertionError: assert False\n"
"E + where False = <function isfile at 0x000002D095AFF160>('C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so. - 1080.f248.webm')\n"
"E + where <function isfile at 0x000002D095AFF160> = <module 'ntpath' from 'C:\\\\Users\\\\Adrien\\\\mambaforge\\\\envs\\\\ICONO-prod\\\\lib\\\\ntpath.py'>.isfile\n"
"E + where <module 'ntpath' from 'C:\\\\Users\\\\Adrien\\\\mambaforge\\\\envs\\\\ICONO-prod\\\\lib\\\\ntpath.py'> = os.path\n"
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.f248.webm\n"
"Destination: C:/Users/Adrien/AppData/Local/ICONO/ICONO_TESTS/yt-videos/ICONO in a minute or so - 1080.f248.mov\n"
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 0.1% of ~ 966.70KiB at 43.60KiB/s ETA 00:22 (frag 0/1)\n"
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 0.3% of ~ 966.70KiB at 127.60KiB/s ETA 00:07 (frag 0/1)\n"
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 0.7% of ~ 966.70KiB at 291.21KiB/s ETA 00:03 (frag 0/1)\n"
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 1.6% of ~ 966.70KiB at 610.67KiB/s ETA 00:01 (frag 0/1)\n"
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 3.2% of ~ 966.70KiB at 1.21MiB/s ETA 00:00 (frag 0/1)\n"
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 6.5% of ~ 966.70KiB at 2.30MiB/s ETA 00:00 (frag 0/1)\n"
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 13.1% of ~ 966.70KiB at 4.33MiB/s ETA 00:00 (frag 0/1)\n"
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 26.4% of ~ 966.70KiB at 8.06MiB/s ETA 00:00 (frag 0/1)\n"
"DEBUG : 35954 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 52.9% of ~ 966.70KiB at 14.72MiB/s ETA 00:00 (frag 0/1)\n"
"DEBUG : 35955 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 100.0% of ~ 966.70KiB at 25.08MiB/s ETA 00:00 (frag 0/1)\n"
"DEBUG : 35955 ms [Thread 140114533140224] src.back.download.ytdlp.execute_command:25 || STDOUT: [download] 100.0% of ~ 966.70KiB at 24.67MiB/s ETA 00:00 (frag 1/1)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")