import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ЪЧЖОА(.*?)ЪУЪ";
final String string = "Стоит задача реализовать редактор контента, который может загружать видео, аудио и создавать фотогалерею. Задача выполнена, но теперь нужно полученный контент отобразить на другом сайте в соответствии с дизайном. То есть блок с фотогалереей в редакторе имеет один вид, а на сайте он должен выглядеть совершенно иначе. ЪЧЖОА{\"dom_type\" : \"photo\", \"url\" : \"x\", \"desc\" : \"y\"}ЪУЪЯ решил, что в момент сохранения контента в редакторе, все блоки (видео, аудио и фотогалереи) переходят в json объекты и записываются в базу, а на сайте PHP код будет парсить эти объекты и выводить их визуально так, как задумано дизайнером. Пока что я дошел только до такого решения, если у вас есть другие предложения - пожалуйста, расскажите о них. ЪЧЖОА{\"dom_type\" : \"gallery\", \"photos\" : [{\"photoAuthor\":\"2\",\"photoSrc\":\"background-image: url(\\\"http://localhost/uploads/photo/4078160325f4fdfc19ab074.38011211.jpeg\\\");\"},{\"photoAuthor\":\"1\",\"photoSrc\":\"background-image: url(\\\"http://localhost/uploads/photo/1934401955f4fdfc1a87489.25544323.jpeg\\\");\"}]}ЪУЪПока что все работает так как надо, мне нужно только обучить редактор находить упомянутые выше блоки (json объекты) в тексте и превращать их в визуальные блоки, чтобы человек видел их как полноценную фотогалерею или видеозапись";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}