use strict;
my $str = 'Стоит задача реализовать редактор контента, который может загружать видео, аудио и создавать фотогалерею. Задача выполнена, но теперь нужно полученный контент отобразить на другом сайте в соответствии с дизайном. То есть блок с фотогалереей в редакторе имеет один вид, а на сайте он должен выглядеть совершенно иначе. ЪЧЖОА{"dom_type" : "photo", "url" : "x", "desc" : "y"}ЪУЪЯ решил, что в момент сохранения контента в редакторе, все блоки (видео, аудио и фотогалереи) переходят в json объекты и записываются в базу, а на сайте PHP код будет парсить эти объекты и выводить их визуально так, как задумано дизайнером. Пока что я дошел только до такого решения, если у вас есть другие предложения - пожалуйста, расскажите о них. ЪЧЖОА{"dom_type" : "gallery", "photos" : [{"photoAuthor":"2","photoSrc":"background-image: url(\\"http://localhost/uploads/photo/4078160325f4fdfc19ab074.38011211.jpeg\\");"},{"photoAuthor":"1","photoSrc":"background-image: url(\\"http://localhost/uploads/photo/1934401955f4fdfc1a87489.25544323.jpeg\\");"}]}ЪУЪПока что все работает так как надо, мне нужно только обучить редактор находить упомянутые выше блоки (json объекты) в тексте и превращать их в визуальные блоки, чтобы человек видел их как полноценную фотогалерею или видеозапись';
my $regex = qr/ЪЧЖОА(.*?)ЪУЪ/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}