import re
regex = re.compile(r"ЪЧЖОА(.*?)ЪУЪ", flags=re.MULTILINE)
test_str = "Стоит задача реализовать редактор контента, который может загружать видео, аудио и создавать фотогалерею. Задача выполнена, но теперь нужно полученный контент отобразить на другом сайте в соответствии с дизайном. То есть блок с фотогалереей в редакторе имеет один вид, а на сайте он должен выглядеть совершенно иначе. ЪЧЖОА{\"dom_type\" : \"photo\", \"url\" : \"x\", \"desc\" : \"y\"}ЪУЪЯ решил, что в момент сохранения контента в редакторе, все блоки (видео, аудио и фотогалереи) переходят в json объекты и записываются в базу, а на сайте PHP код будет парсить эти объекты и выводить их визуально так, как задумано дизайнером. Пока что я дошел только до такого решения, если у вас есть другие предложения - пожалуйста, расскажите о них. ЪЧЖОА{\"dom_type\" : \"gallery\", \"photos\" : [{\"photoAuthor\":\"2\",\"photoSrc\":\"background-image: url(\\\"http://localhost/uploads/photo/4078160325f4fdfc19ab074.38011211.jpeg\\\");\"},{\"photoAuthor\":\"1\",\"photoSrc\":\"background-image: url(\\\"http://localhost/uploads/photo/1934401955f4fdfc1a87489.25544323.jpeg\\\");\"}]}ЪУЪПока что все работает так как надо, мне нужно только обучить редактор находить упомянутые выше блоки (json объекты) в тексте и превращать их в визуальные блоки, чтобы человек видел их как полноценную фотогалерею или видеозапись"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")