package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[].+.[].+`)
var str = `text cust.main.city here
cust.main.city text here
text here cust.main.city
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}