import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\*.*\\s)+";
final String string = "## Title\n\n"
+ "This is some text hehe haha\n\n"
+ "* List starting here\n"
+ "* another list Item\n"
+ "* Maybe another\n"
+ " \n"
+ "Here text again";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}