re = /(?:\*.*\s)+/m
str = '## Title
This is some text hehe haha
* List starting here
* another list Item
* Maybe another
Here text again'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end