#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\(]\(([^\(\)]+)\)[^\)]"
Local $sString = "ab(ab)ac" & @CRLF & _
"(ab)ndn" & @CRLF & _
"ab(ab(ac)an)" & @CRLF & _
"ab((ab)ab)ab" & @CRLF & _
"ab(ab(abb))ab" & @CRLF & _
"ab(ab(ab(ab))ab)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")