package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\(]\(([^\(\)]+)\)[^\)]`)
var str = `ab(ab)ac
(ab)ndn
ab(ab(ac)an)
ab((ab)ab)ab
ab(ab(abb))ab
ab(ab(ab(ab))ab)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}