re = /[^\(]\(([^\(\)]+)\)[^\)]/m
str = 'ab(ab)ac
(ab)ndn
ab(ab(ac)an)
ab((ab)ab)ab
ab(ab(abb))ab
ab(ab(ab(ab))ab)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end